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Accessing Stata

Stata can be acquired for home use (see "Aquiring Stata" on the class web page) or it may be accessed at the Health Sciences Computer Microlab (3rd floor T-wing, Health Sciences building). The following instructions will assume you are working at the Microlab.

To start Stata, click on "StataIC 11" from the Windows Start > Programs > Stata 11 menu. When you start up Stata you get one large "Stata" window. Contained within that are 4 smaller windows. These smaller windows include a “Command” window (for typing in commands), a “Review” window (listing  the commands you have entered), a “Variables” window (listing the variables in the current dataset) and a “Results” window (giving results of commands). Additional windows, such as a help window and a graphics window are created as needed by the system.

To exit Stata, type

exit

in the command window and press the enter key (or just click on X in the upper right hand corner of the window.
Stata data - how Stata thinks about data
At any given time, Stata keeps a single dataset stored in its memory. The data are organized in rows (called records) and columns (called variables). If you have used Excel or another spreadsheet program you are familiar with this format. The variables are identified by names and the records by numbers. This “rectangular” format can be a bit clumsy at times … for instance, if you have data from repeated visits for a given person, should you organize it as one row per person-visit or one row per person (with a different variable for each visit i.e. bldpress1, bldpress2, bldpress3 to represent blood pressure at the first 3 visits)? Fortunately, Stata has a command – reshape – that allows you to switch back and forth between the two formats.

Most of the mathematical or statistical operations in Stata work on all the records at once but you can temporarily select subsets of the data (i.e. only the records for men) to work on.

Getting Stata to do stuff – commands and menus
Originally, Stata was developed as a command driven package, meaning that you had to type in commands to make it do things. The problem with that approach is that you need to know (and remember) the syntax of key commands before you can get anything done. This is tough when you first start using the program! 

Starting with Stata 8 and continuing through Stata 11, however, Stata now comes with a drop-down menu system. If you look across the top of the main Stata window you will see the words File, Edit, Data, etc (actually, you don’t really see “etc” …). 

[image: image1.png]Stata/IC 11.0- [Results]

Fle Edt Data Graphics Statistis User Window Help

Clrikz B EHBIEI 00





Click on any of these to see the submenus that are available. You can accomplish 90% or more of what you need to do through the menuing system. In addition, every time you do something through the menuing system, Stata automatically generates the corresponding command in the review window. By looking at these commands you can learn the Stata command language.

Getting Help
Stata comes with the following documentation (which are available in paper form at the Microlab and online as pdf’s). It is REALLY helpful to read the Getting Started guide completely …
Getting Started [GSW]

User's Guide [U]

Reference Manuals (multiple vols) [R]

Graphics Manual [G]

Stata also has an on-line help system that can be accessed by choosing Help from the menu bar. When you click on Help you get the following submenu

Advice


Overview of how to get help
Contents

See the help table of contents
Search…

Search for help on a particular topic

Stata Command…
Get help for a particular Stata command

  :

  :

If you are a new user it is useful to browse through the table of Contents just to get an idea of what the package can do. Search is useful if you have a general topic you are interested in but don't know the actual command.

The online help pages are fairly terse – they give the full command syntax (with hyperlinks to related topics in blue) but no examples, background or other information. The hard copy reference manuals and online pdf files have additional information.
People who are planning to use Stata for research and want intensive instruction might consider the NetCourses offered by Stata Corporation (http://www.stata.com/info/products/netcourse/)

Log files

It’s useful to start a log file when using Stata. This keeps a record of everything you type and everything Stata displays so you can print out the results. You can edit the log file and use it to create "do" files that can be used to repeat commands at a later date. To open a log file do File > Log > Begin and choose a name and location for your log file. Click Ok to continue. If you look closely you will also notice an icon that looks like a scroll just below the menu bar. Clicking on the scroll icon will also start a log file.
The log file will record all your commands and output. You can temporarily suspend recording using File > Log > Suspend. When you are completely finished with the log file, use File > Log > Close.
As an aside, you don’t need to use log files. I tend to just open a MS-Word document and cut and paste my results into that document as I go. That’s useful for doing your homework because I don’t want to see all your Stata code and all your raw output. The downside, however, is that you don’t have a complete record of what you did in case you need to recreate something.

Inputting and saving data
To get data into Stata you can type it in using the data editor, read the data in from a text file, or recall a previously saved Stata data file (typically with extension .dta). These options are described further below. If a dataset already exists in Stata’s memory you must clear it using the clear command before a new dataset can be entered. You can also create data with the generate command. Once data has been entered, you typically will want to save the data using the save command or File > Save As.
· Typing in data

To enter data manually into Stata, type

edit

in the command window or choose Data > Data Editor > Data Editor (Edit) from the menus (note: if you enter the data editor in browse model, you can’t change the data). This starts the Stata data editor. The data editor uses a spreadsheet format with columns representing the variables and rows representing the observations in your dataset. Simply type the data into the spreadsheet. Strings do not need to be quoted and missing values are entered as a period (.) for numeric data or blank for character data. The default names for the variables (the columns) are var1, var2, etc. To change any variable's name, click on Data > Variables Manager. In the Variable Manager you can also enter a label for the variable, change the format for the variable and enter value labels (see Documenting a Dataset, below). 
To close the editor, click on the X in the upper right hand corner. All changes are automatically saved in the version of the data that is in Stata’s memory. However, you’ll still need to save the dataset to a disk somewhere using the Save command (that is explained below).
· Inputting from a text file

Often data will be available in the form of a text file. Stata has a bunch of commands to read text files -  infile1 (same as infile), infile2, infix insheet – see the help page for “infiling” for more detail. However, this is one area where the menu system is easier to use. Go to File > Import and click on Unformatted ASCII data. This opens a dialog box …
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In the filename box type (e.g.)
http://courses.washington.edu/b511/datasets/hiv.dat
and for variable names type (e.g.)

id blood cd4 art

In general, strings or character data should be quoted (there are exceptions) and missing values are input as period (.) for numeric data and blank ("") for character data. The other option you may find useful in the File > Import menu is ASCII data created by a spreadsheet.
Once you have input the data, you can view it with the 

browse

command. When you are in browse, you cannot alter the data. Use edit if you want to change the data using the data editor. 

· Using an existing Stata dataset

When you save data using the save command (see below), Stata saves the data in a special format (along with labels and other information) and uses the file extension .dta. To open an existing Stata dataset type

use <path\filename>

or File > Open from the menus.

· Saving Data

To save the current dataset to disk, type

save "<path\filename>"
on the command line or

save "<path\filename>", replace
if filename already exists or choose File …. Save As from the menu. If <path> is not given then the data is saved to the Stata Data directory (usually C:\DATA). If you are working on the Health Science Microlab system you need to change <path> to your temporary folder e.g. 

save "c:\temp\hiv"

or save the file to a device on the E drive

save “E:hiv”

To clear a dataset from memory type

clear

on the command line. If the dataset has not been previously saved to disk, this will erase the data permanently.

Documenting a Dataset

You can alter variable names, labels, formats, create/change value labels  and add notes to the dataset through the Data > Variables Manager window. Click on Data > Variables Manager and you will see the following (note: I have imported the HIV dataset mentioned above)
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Usually, you will want to make variable names short since you will be typing them a lot (e.g. wt for weight). However, it is convenient to have more complete descriptions of the data attached to the dataset so that when you come back a year latter you can remember what everything means. Labels and notes are used for this purpose. Here I have added labels to the variables in the dataset by selecting each variable in turn and entering the label in the box by the arrow.
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You could also type the commands

 label variable blood "HIV-1 plasma viral load (copies/ml)"

 label variable cd4 "CD4 T-cell count (cells/ul)"

 label variable art "Antiretroviral therapy"

You can also create value labels to label the values of categorical variables. Stata is similar to SAS in the way it does this … you first define a label and then you attach that label to one (or more) variables. Via the command window you can do this:

label define agegroups 1 "25-24" 2 "35-44" 3 "45-54" 4 "55-64" 5 "65-74" 6 "75+"

label values age agegroups

label define answer 1 "yes" 0 "no"

label values Q1 answer

label values Q2 answer

label values Q3 answer

Using the menuing system, click on the Manage button next to Value Labels and then Create Label. Here I have created a label called “yesno” with 0 meaning “No” and 1 meaning “Yes”:
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After closing the Create Label window and the Manage Value Labels window, I can apply the label to a variable, in this case art:
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If you go into the dataset (using Data > Data Editor > Data Editor (Browse)) you will see that all the 0’s and 1’s for the art variable have been changed to No’s and Yes’s:
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You may also use 

note: <note phrase>
in the command window to add a note to the entire dataset.

Creating and Transforming Variables

You can create new variables with the generate command or replace existing variables with the replace command (also available through the Data … Create or change data menu). The recode command is used to code variables into categories. E.g.

generate lwt = ln(wt)


* makes a new variable, lwt, equal to the natural log of wt

replace wt = ln(wt)



* replaces wt with the natural log of wt

generate rnum = uniform() < 0.5

* generate 5 random 0/1 random numbers

generate htgrp = ht



* copy ht to htgrp

recode htgrp  0/71=1 72/83=2 84/100=3
* recode htgrp into categories

Summarizing Data

The following commands are useful for describing and summarizing data. These first few are dataset description/documentation commands and are available on the Data menu.
describe

* describes the dataset, giving variables names and labels

list


* lists the data, using value labels if they have been supplied
notes


* prints out any notes you have added to the dataset
The following commands summarize data and are available under the Statistics > Summaries, tables & tests menu

summarize

* prints number of obs., mean, standard dev., min. and max. for each variable

tabulate <var1><var2>…
* crosstabulates <var1> by <var2> by …; if only one <var> is listed     a frequency table is given

I recommend ALWAYS doing describe and summarize when you first read in a new dataset.

Graphics

The graphics capabilities of Stata have improved/increased quite a bit in recent versions so I tend to make a first pass at any graph I want to do using the Graph drop-down menu. Sometimes, if I want to do something fancy (like overlaying graphs) I’ll then have to go to the documentation and build on the command that was generated from the menu system. In version 10 Stata introduced a graphics editor, shown below. Click on this button in any graph to access the editor.
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 I recommend that if you are going to be printing your graphs (e.g. to hand in for homework) that you go to the Edit > Preferences > Graph Preferences menu and choose “s1 monochrome”.
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Getting Output

When working at the Health Sciences microcomputer lab you can get printed and graphic output by sending output to the printer using the Stata print functions (found under the File menu). The cost of printed output is 5 cents/page and you can use a library copicard or cash. The Microlab personnel can provide further instruction on obtaining your output.

A sample Stata session

******************** Use * at the beginning of the line to enter a comment ********************

*

* Start a log file by clicking on the log button

. edit

. * enter the following data for var1

. * 72 65 84 73 68

. * enter the following data for var2

. * 165 120 210 180 125

.* now click on Data > Variable Manager
. *change the name of var1 to ht and add the label "height (in.)"; click Apply
.* change the name of var2 to ht and add the label "weight (lbs)" ; click Apply
.* close the Variable Manager by clicking on the X in the upper right hand corner

. * close the edit window by clicking on the X in the upper right hand corner of the edit window

. describe

Contains data

  obs:             5                          

 vars:             2                          

 size:            35 (99.9% of memory free)

-----------------------------------------------------------------------

   1. ht        byte   %8.0g                  height (in.)

   2. wt        int    %8.0g                  weight (lbs)

-----------------------------------------------------------------------

Sorted by:  

     Note:  dataset has changed since last saved
. summarize

Variable |     Obs        Mean   Std. Dev.       Min        Max

---------+------------------------------------------------------

    ht   |       5         72.4   7.231874        65         84

    wt   |       5        160    37.91438        120        210
.scatter ht wt
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. clear

. infile id blood cd4 art using "http://courses.washington.edu/b511/datasets/hiv.dat"
(128 observations read)
. label variable blood "HIV-1 plasma viral load (copies/ml)"

. label variable cd4 "CD4 T-cell count (cells/ul)"

. label variable art "Antiretroviral therapy"

. label define yesno 0 "No" 1"Yes"

. label values art yesno 

. describe

Contains data

  obs:           128                          

 vars:             4                          

 size:         2,560 (99.6% of memory free)

-----------------------------------------------------------------------
   1. id        float  %9.0g                  

   2. blood     float  %9.0g                  HIV-1 plasma viral load

                                                (copies/ml)

   3. cd4       float  %9.0g                  CD4 T-cell count (cells/ul)

   4. art       float  %9.0g       yesno      Antiretroviral therapy

-----------------------------------------------------------------------
Sorted by:  

     Note:  dataset has changed since last saved

. summarize

<OUTPUT> 

. histogram blood, bin(5)

/* Note: Change the argument of  bin( ) to change the number of bins */

<GRAPH>

. generate lblood = log10(blood)

(4 missing values generated)

. label variable lblood "log10 viral load level"

. histogram lblood, bin(5)

<GRAPH>

. summarize blood, detail

<OUTPUT>

. graph box lblood, medtype(line) by(art)
. by art, sort : summarize lblood, detail
<OUTPUT>

* save the dataset on your own disk if you want to …

. save "A:\hiv.dta"

. exit
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